Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 14, 2026 - 23:00 GMT-03:00
Scheduled
As part of our ongoing commitment to security and service reliability, we will be conducting critical scheduled maintenance on our Cloud Manager & API infrastructure and Email Services platform. This essential intervention includes the application of high-priority security patches, configuration updates, and performance optimizations.
During this maintenance window, the Cloud Manager & API, Email Platform, and Webmail Access services may be temporarily unavailable or experience intermittent degradation. Customers relying on these services may face brief interruptions during the process.
Our specialized team will actively monitor and manage this maintenance to ensure a swift, secure, and controlled execution, minimizing the impact on your daily operations.
We appreciate your understanding and patience.
Posted Mar 14, 2026 - 22:26 GMT-03:00
This scheduled maintenance affected: Email Services (Email Platform, Webmail Access) and Cloud Manager & API.